    <!DOCTYPE html>
<!-- Powered by RebelMouse. https://www.rebelmouse.com -->
<html lang="en">
<head prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#"><link rel="preload" as="script" href="https://www.googletagmanager.com/gtag/js?id=UA-18141479-1"><link as="font" href="https://fonts.gstatic.com/s/oswald/v36/TK3iWkUHHAIjg752GT8G.woff2" type="font/woff2" crossorigin="" rel="preload"></link><link rel="apple-touch-icon" sizes="57x57" href="https://assets.rbl.ms/24986912/origin.png" /><link rel="apple-touch-icon" sizes="72x72" href="https://assets.rbl.ms/24986920/origin.png" /><link rel="apple-touch-icon" sizes="114x114" href="https://assets.rbl.ms/24987652/origin.png" /><link rel="apple-touch-icon" sizes="144x144" href="https://assets.rbl.ms/24987654/origin.png" /><link rel="apple-touch-icon" sizes="180x180" href="https://assets.rbl.ms/24987667/origin.png" /><link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://assets.rbl.ms/24986912/origin.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://assets.rbl.ms/24986920/origin.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://assets.rbl.ms/24987652/origin.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://assets.rbl.ms/24987654/origin.png" /><link rel="apple-touch-icon-precomposed" sizes="180x180" href="https://assets.rbl.ms/24987667/origin.png" /><meta name="msapplication-TileImage" content="https://assets.rbl.ms/24986912/origin.png"><meta name="msapplication-square70x70logo" content="https://assets.rbl.ms/24986920/origin.png"><meta name="msapplication-square150x150logo" content="https://assets.rbl.ms/24987654/origin.png"><meta name="msapplication-wide310x150logo" content="https://assets.rbl.ms/24986936/origin.png "><meta name="msapplication-square310x310logo" content="https://assets.rbl.ms/24986936/origin.png "><link rel="mask-icon" href="https://assets.rbl.ms/24987652/origin.png" color="#000" /><link rel="preload" href="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMzg0MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NTExMjUyMH0.9285uted0XHXZND3qB3e2gdAH_sJJwNi9ZipuOukFuc/image.jpg?width=1200&quality=85&coordinates=42%2C0%2C104%2C0&height=800" as="image"><link rel="preload" href="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMzg0MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NTExMjUyMH0.9285uted0XHXZND3qB3e2gdAH_sJJwNi9ZipuOukFuc/image.jpg?width=1200&amp;height=680" as="image">
    <meta name="twitter:card"               content="summary_large_image">
<meta name="twitter:site"               content="@">
<meta name="twitter:site:id"            content="">
<meta name="twitter:image"              content="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMzg0MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NTExMjUyMH0.9285uted0XHXZND3qB3e2gdAH_sJJwNi9ZipuOukFuc/image.jpg?width=1200&coordinates=0%2C66%2C0%2C0&height=600">
<meta property="fb:app_id"              content="1564913360486006">
<meta property="og:type"                content="article">
        <meta property="og:url" content="https://www.rawstory.com/wendy-rogers-arizona/">
        <link rel="canonical" href="https://www.rawstory.com/wendy-rogers-arizona/" />
    <meta property="og:site_name"           content="Raw Story - Celebrating 17 Years of Independent Journalism">
    
<meta property="og:image"               content="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMzg0MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NTExMjUyMH0.9285uted0XHXZND3qB3e2gdAH_sJJwNi9ZipuOukFuc/image.jpg?width=1200&coordinates=0%2C66%2C0%2C0&height=600">
<meta property="og:image:width"               content="1200">
<meta property="og:image:height"               content="600">
    <meta property="og:title"               content="Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials">
    <meta property="og:description"         content="Trump-loving Arizona State Sen. Wendy Rogers lashed out at the Maricopa County Board of Supervisors after it refused to comply the Arizona Republicans&#39; demands for more information related to the Trump-backed &#34;audit&#34; of the 2020 election.After Jack Sellers, the chair of the board, wrote a snide lett...">

<meta name="referrer" content="always" />

    <meta charset="utf-8">
    <link rel="preconnect" href="https://assets.rebelmouse.io/" crossorigin>
    <link rel="preconnect" href="https://user-stats.rbl.ms/" crossorigin>
    <link rel="preconnect" href="https://pages-stats.rbl.ms/" crossorigin>
    <!--link rel="preload" href="https://static.rbl.ms/static/fonts/fontawesome/fontawesome-mini.woff" as="font" type="font/woff2" crossorigin-->
    <script>window.REBELMOUSE_BOOTSTRAP_DATA = {"engine": {"changeParticleUrlScroll": true, "lazyLoadShortcodeImages": false, "theoPlayerLibraryLocation": "", "defaultVideoPlayer": "", "backButtonGoToPage": true, "webVitalsSampleRate": 100, "countKeepReadingAsPageview": true, "uplynkAdsConfig": "", "trackPageViewOnParticleUrlScroll": true}, "isUserLoggedIn": false, "runner": {"id": 20266338}, "resourceId": "pp_2654381056", "section": {"id": null}, "fbId": "1564913360486006", "site": {"id": 20266338}, "messageBusUri": "wss://messages.rebelmouse.io", "tag": {"slug": null}, "clientGaId": "UA-18141479-1", "post": {"sections": [0, 532450088, 537910665, 504781448, 502613554, 535969657], "shareUrl": "https%3A%2F%2Fwww.rawstory.com%2Fwendy-rogers-arizona%2F", "id": 2654381056}, "fbAppVersion": "v2.5", "pathParams": {"sections": "", "slug": "wendy-rogers-arizona"}, "fullBootstrapUrl": "/res/bootstrap/data.js?path_params=%7B%22sections%22%3A%22%22%2C%22slug%22%3A%22wendy-rogers-arizona%22%7D\u0026post_id=2654381056\u0026site_id=20266338\u0026override_device=desktop\u0026resource_id=pp_2654381056"};
    </script>
    <script>
        window.REBELMOUSE_BASE_ASSETS_URL = "https://www.rawstory.com/static/dist/social-ux/";
        window.REBELMOUSE_BASE_SSL_DOMAIN = "https://www.rawstory.com";
        window.REBELMOUSE_TASKS_QUEUE = [];
        window.REBELMOUSE_LOW_TASKS_QUEUE = [];
        window.REBELMOUSE_LOWEST_TASKS_QUEUE = [];
        window.REBELMOUSE_ACTIVE_TASKS_QUEUE = [];
        window.REBELMOUSE_STDLIB = {};
        window.RM_OVERRIDES = {};
    </script>
    <script type="module" async src="https://www.rawstory.com/static/dist/social-ux/main.0a8a37a9029e8fe43869.bundle.mjs"></script>
    <script nomodule defer src="https://www.rawstory.com/static/dist/social-ux/main.7cf66e258d3adbf9d9c5.bundle.js"></script>

    <script type="module" async src="https://www.rawstory.com/static/dist/social-ux/runtime.7fa3a050297881c6bbf8.bundle.mjs"></script>
    <script nomodule defer src="https://www.rawstory.com/static/dist/social-ux/runtime.acc5949182747b1f0c73.bundle.js"></script>

    
    <!-- we collected enough need to fix it first before turn in back on-->
    <!--script src="//cdn.ravenjs.com/3.16.0/raven.min.js" crossorigin="anonymous"></script-->
    <!--script type="text/javascript">
        Raven.config('https://6b64f5cc8af542cbb920e0238864390a@sentry.io/147999').install();
    </script-->
    <link rel="manifest" href="/manifest.json">
    <meta name="theme-color" content="#647187"/><script>
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/sw.js').then(function(registration) {
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }, function(err) {
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        } else {
          console.log('ServiceWorker not enabled');
        }
    </script>
    <script>
        // fallback error prone google tag setup
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

    

    

    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    
    
        
        <link rel="alternate" type="application/rss+xml" title="Raw Story - Celebrating 17 Years of Independent Journalism" href="/feeds/hot-off-the-wires.rss" />
        
    
    


    <!-- Mobile viewport optimized: h5bp.com/viewport -->
    <meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1.0,maximum-scale=1.0,user-scalable=no">

    

    

    

    <title>Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials - Raw Story - Celebrating 17 Years of Independent Journalism</title>
    
    
    
    <style>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</style>
    <script>
        window.REBELMOUSE_LOW_TASKS_QUEUE.push(function() {
            window.REBELMOUSE_STDLIB.loadExternalStylesheet("/static/css-build/roar/runner/social-ux-non-critical.css?v=rmxassetsdcf4a2e8b4769c7abd69b9558d931647RMCSS", function(){
                document.body.classList.add("rm-non-critical-loaded");
            });
        });
    </script>
    
    <script>
        var __RUNNER_PUBLIC__ = {
          root: '#runner-root',
          events: {
            PAGE_VIEW: 'page_view.url_change.listicle_switch_page',
            URL_CHANGE_PAGE_VIEW: 'page_view.url_change',
            LISTICLE_CHANGE_PAGE_VIEW: 'page_view.listicle_switch_page'
          }
        }
    </script>
    <script>
        window.__rebelmouseJsBaseUrl = "/static/js-build/";
        
        window.__rebelmousePrimaryColor = "#dd3030";
        
    </script>
    
    
    
    
    
    <link rel="apple-touch-icon"      href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDk4Njk1My9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1MTEyMjcxNX0.qi-Z4LJtaEielvre82N35RMuArdX_vGZ3yn8lskyOjs/img.png?width=192&amp;height=192" sizes="192x192"/>
<link rel="icon" type="image/png" href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDk4Njk1My9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1MTEyMjcxNX0.qi-Z4LJtaEielvre82N35RMuArdX_vGZ3yn8lskyOjs/img.png?width=32&amp;height=32"   sizes="16x16"/><meta property="article:published_time" content="2021-08-02T23:38:09+00:00" /><meta property="article:modified_time" content="2021-08-02T23:39:27+00:00" /><meta property="article:author" content="https://www.facebook.com/20324257234" /><meta name="description" content="Trump-loving Arizona State Sen. Wendy Rogers lashed out at the Maricopa County Board of Supervisors after it refused to comply the Arizona Republicans' demands for more information related to the Trump-backed &quot;audit&quot; of the 2020 election.After Jack Sellers, the chair of the board, wrote a snide lett..."/><link rel="amphtml" href="https://www.rawstory.com/amp/wendy-rogers-arizona-2654381056"><!-- <meta property="cXenseParse:author" content="{{context.post.roar_authors[0].title}}" /> {{post.basename}} --><!-- <jinja>{{context.post.roar_authors[0].title}}</jinja> --><meta name="cXenseParse:taxonomy" content="US News" /><meta name="google-site-verification" content="-U7zwrUODo2tQoVU8xG0l0ZvwOQelGxHP_gSSRtA2Do" /><meta name="google-site-verification" content="yhVmRXl20HGayZoKcjS1bFukkqpDG3Z54diyjfHF6o0" /><!-- Ben Search Console --><meta property="fb:pages" content="20324257234" /><meta property="fb:pages" content="20324257234" /><script>
	
  	/* CB CODE *
  
	
     */
  
</script><meta name="google-site-verification" content="UQ0KHHsx9uXELj5kwikToRz8-HCRpNQRmpJnYDgAjkk" /><meta name="google-site-verification" content="DaMOYobcHatjp6A25M4YqKIH4HuDzklevz-cB23nHJ0" /><style id="custom-post-styles-2654381056">
</style><style id="custom-post-styles-2654379262">
</style><style id="custom-post-styles-2654378836">
</style><style id="custom-post-styles-2654379553">
</style><style id="custom-post-styles-2651368033">
</style>

    


    <script>
    
        (function() {
    var cookie = 'rebelmouse_abtests=';
        cookie += '; Max-Age=0';
    document.cookie = cookie + '; Path=/; SameSite=None; Secure';
})();
    
    </script>


    <!--[if IE]>
        <script type="text/javascript" src="/static/js-build/libs/html5shiv/html5shiv.js"></script>
    <![endif]-->
</head>

<body 
    class="logged-out-user section-hot-off-the-wires"
 >
    <div id="fb-root"></div>
    <div id="runner-root"></div>
    
    <div id="curtain" class="curtain"></div>
    
    <nav class="menu-global">
    <div class="main-menu-wrapper">
        <div class="menu-global__search-form hide-tablet-and-desktop">
            <form action="/search/">
                <button aria-label="Submit" type="submit" class="menu-global__submit fa fa-search" value=""></button>
                <input aria-label="Search" placeholder="Search..." type="text" name="q" class="menu-global__text-input"></input>
            </form>
        </div>
        <div class="divider hide-tablet-and-desktop"></div>
        <ul class="sections-list"></ul>
            <div class="divider"></div>
        <ul id="main-menu" class="main-menu">
    <li class="main-menu-item main-menu-item--subscriptions">
        <a href="/core/r_dashboard/subscriptions" class="link" title="Subscriptions"><i class="ico settings"></i>Subscriptions
        </a>
    </li>
    <li class="main-menu-item main-menu-item--login">
        <a href="/login" class="link" title="Log in">Log in
        </a>
    </li>
</ul></div>
</nav><extra_asset_fields></extra_asset_fields><post_types_supported></post_types_supported><site_specific_data_schema></site_specific_data_schema><post_image_settings _3x2="true" _1x1="true" _3x1="true" _3x4="true" _2x1="true" _9x16="true" _16x9="true" _4x3="true"></post_image_settings><div class="all-content-wrapper">
        <div class="main v-sep">
                <span class="js-brick-description hidden" data-name="Post"></span><!-- User Code --><style>
.social-date {
  margin-top: -5px !important;
  display: none !important;
}
.social-author .social-date {
  display: block !important;
}
.rs_ad_block.story_page_before_content { 
  display: none !important;
 }
</style><!-- End User Code --><div data-share-status-id="menu-toggle" class="menu-overlay js-toggle" data-target="body" data-toggle-class="menu-opened"></div><!-- User Code --><script>
window.propertag = window.propertag || {};
window.propertag.cmd = window.propertag.cmd || [];
window.googletag = window.googletag || {cmd: []};
window.cnxps={},window.cnxps.cmd=[];
window.cnx={},window.cnx.cmd=[];
window.cnxFlag=true;
  
_qoptions={ qacct:"p-76DHYTY06o6yQ" };
</script><!-- End User Code --><!-- User Code --><div id='div-gpt-ad-1580400905899-0' style="margin:0"></div><!-- End User Code --><!-- User Code --><noscript><img src="https://pixel.quantserve.com/pixel/p-76DHYTY06o6yQ.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></noscript> 
<!-- End User Code --><!-- User Code --><div class='rs_ad_block sitewide-startofbody' style='margin: 0 auto; text-align: center; '><div class="proper-ad-unit ad-sticky rs_ad_block"><div id="proper-ad-rawstory_sticky_1"></div></div></div><!-- End User Code --><div class="topbar-wrapper" id="sTop_Bar_0_0_8_0_0_14"><div class="top-site-header" id="sTop_Bar_0_0_8_0_0_14_0"><div class="site-header__inner" id="sTop_Bar_0_0_8_0_0_14_0_0"><div class="left-buttons" id="sTop_Bar_0_0_8_0_0_14_0_0_0"><a id="sTop_Bar_0_0_8_0_0_14_0_0_0_0"
    class="display-block image-element">
    <img
        class="image-element__img"
        alt=""
        width="450"
        height="84"src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDc4ODY4OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1NjI5NTE4NX0.hX5q_6ecaT2TF32vwz-4YA47AVgf04Z3IZKWkMDHfto/img.png?width=450&amp;height=84"
    />
</a><div class="left-images" id="sTop_Bar_0_0_8_0_0_14_0_0_0_1"><a id="sTop_Bar_0_0_8_0_0_14_0_0_0_1_0"
    class="display-block image-element"href="/st/rawstory-invest-in-reader-driven-journalism" target="_blank">
    <img
        class="image-element__img"
        alt=""
        width="345"
        height="50"src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNTYxNTA3Ny9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY1NDExNjY5Nn0.v-y-Xv_4nekIXm46EAwz9YQvvSNJtDTfkm2Kt4LDqsE/img.gif?width=345&amp;height=50"
    />
</a></div><a id="sTop_Bar_0_0_8_0_0_14_0_0_0_2"
    class="display-block image-element"href="https://kindest.com/993447-donate-the-fight-is-not-over-invest-in-courageous-progressive-journalism" target="_blank">
    <img
        class="image-element__img"
        alt=""
        width="205"
        height="50"src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNTYxNTA3Ni9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY2NjY4MTkxMX0.EkXArXxchYgc5-Lj-VlraoVgiYjr-394Pfk37ENyxeo/img.gif?width=205&amp;height=50"
    />
</a></div><div class="tablet-menu-search" id="sTop_Bar_0_0_8_0_0_14_0_0_1"><!-- User Code --><div class="custom-menu-btn"><span class="menu-line-1"></span><span class="menu-line-2"></span><span class="menu-line-3"></span><span class="menu-line-4"></span></div><!-- End User Code --></div><div class="main-logo-wrapper" id="sTop_Bar_0_0_8_0_0_14_0_0_2"><!-- User Code --><a class="display-block image-element logo-link" href="/" target="_self"><img class="image-element__img" alt="" src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNTY2Mjk2MS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY3NDQxNTU0Mn0.jaHwrlieZPHEQPfNbeMlQt_azrNlei9PmUa7-5xAvSQ/img.png?width=500&height=77"></a><!-- End User Code --></div><div class="raw-story-investigates" id="sTop_Bar_0_0_8_0_0_14_0_0_3"><!-- User Code --><a href="/st/raw_story_investigates" target="_self"><img class="image-element__img" alt="" src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNTY2Mjk3MC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTYzOTE5NTIyOH0.j-uT9-VmyNbickVg4hmkA6BFhDw43DnmSwid52l-UB8/img.png?width=166&height=60"></a><!-- End User Code --></div><div class="search-container" id="sTop_Bar_0_0_8_0_0_14_0_0_4"><!-- User Code --><a class="search-form__open js-toggle"><i class="fa fa-search"></i></a><!-- End User Code --></div></div></div><!-- User Code --><div id="navi-in-red" class="big-nav"><div class="mobile"><a id="mobile-ad-free-login-link-bignav">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</a> -
<a href="https://www.rawstory.com/st/rawstory-invest-in-reader-driven-journalism">Go Ad-Free &amp; Join The Movement</a></div><div class="tablet"><a href="https://www.rawstory.com/st/rawstory-invest-in-reader-driven-journalism">Don&#8217;t Sit on the Sidelines of History. Support Honest News. Join for $1 today.</a></div><div class="desktop"><script>
			var default_message = '<a href="https://www.rawstory.com/st/rawstory-invest-in-reader-driven-journalism">Don&#8217;t Sit on the Sidelines of History. Support Honest News. Join for $1 today.</a>';
			var blocking_users = 'You are currently not receiving push notifications.  Follow these <a href="https://onesignal.com/bell/chrome-unblock.jpg" style="text-decoration: underline;">instructions</a> to allow them.';
			var undecided_users = 'Cut through the chaos and get the real truth on the U.S. election.';
			var thank_you_message = 'Thanks for subscribing!';
		</script><div id="push-subscription-links-container"><span id="OneSignalStatusContainer"><a href="https://www.rawstory.com/st/rawstory-invest-in-reader-driven-journalism">Don&#8217;t Sit on the Sidelines of History. Support Honest News. Join for $1 today.</a></span><span id='OneSignalButtonsContainer' style='display: none;'><a href="#" id="slide-notification-button" style="text-decoration: underline;">Click to enable push notifications.</a></span></div></div></div><!-- <style>@media (min-width:768px){ #navi-in-red { display: none !important; } )</style> --><!-- End User Code --><div class="top-navigation" id="sTop_Bar_0_0_8_0_0_14_2"><div class="links" id="sTop_Bar_0_0_8_0_0_14_2_0"><!-- User Code --><div class="custom-menu-btn"><span class="menu-line-1"></span><span class="menu-line-2"></span><span class="menu-line-3"></span><span class="menu-line-4"></span></div><!-- End User Code --><div class="list" id="sTop_Bar_0_0_8_0_0_14_2_0_2"><a href="/st/Curated_For_You" class="list__item" target="_self">Curated For You</a><a href="/podcast" class="list__item" target="_self">The Raw Story Podcast</a><a href="/us-news" class="list__item" target="_self">US NEWS</a><a href="/commentary" class="list__item" target="_self">Opinion</a><a href="/all-video" class="list__item" target="_self">video</a><a href="/st/ethics-policy" class="list__item" target="_self">Ethics Policy</a><a href="/st/newsletter-signup " class="list__item" target="_self">get the newsletter</a></div><!-- User Code -->
          
          
          
          <!-- <a class="list__item ad-free-link top-nav" onclick="(function(){window.admiral('show','transact.login')})()"></a>--><a id="piano_login_button" class="list__item ad-free-link top-nav"></a> <!-- End User Code --><!-- User Code --><a class="search-form__open js-toggle"><i class="fa fa-search"></i></a><!-- End User Code --></div></div></div><div class="topbar-tiny-wrapper" id="sTop_Bar_0_0_8_0_0_15"><div class="top-tiny-site-header" id="sTop_Bar_0_0_8_0_0_15_0"><div class="site-header__inner" id="sTop_Bar_0_0_8_0_0_15_0_0"><div class="left-buttons" id="sTop_Bar_0_0_8_0_0_15_0_0_0"><a id="sTop_Bar_0_0_8_0_0_15_0_0_0_0"
    class="display-block image-element">
    <img
        class="image-element__img"
        alt=""
        width="450"
        height="84"src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDc4ODY4OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1NjI5NTE4NX0.hX5q_6ecaT2TF32vwz-4YA47AVgf04Z3IZKWkMDHfto/img.png?width=450&amp;height=84"
    />
</a><div class="left-images" id="sTop_Bar_0_0_8_0_0_15_0_0_0_1"><a id="sTop_Bar_0_0_8_0_0_15_0_0_0_1_0"
    class="display-block image-element"href="/st/rawstory-join-reader-driven-journalism" target="_blank">
    <img
        class="image-element__img"
        alt=""
        width="345"
        height="50"src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNTYxNTA3Ny9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY1NDExNjY5Nn0.v-y-Xv_4nekIXm46EAwz9YQvvSNJtDTfkm2Kt4LDqsE/img.gif?width=345&amp;height=50"
    />
</a></div></div><div class="tablet-menu-search" id="sTop_Bar_0_0_8_0_0_15_0_0_1"><!-- User Code --><div class="custom-menu-btn"><span class="menu-line-1"></span><span class="menu-line-2"></span><span class="menu-line-3"></span><span class="menu-line-4"></span></div><!-- End User Code --></div><div class="main-logo-wrapper" id="sTop_Bar_0_0_8_0_0_15_0_0_2"><!-- User Code --><a class="display-block image-element logo-link" href="/" target="_self"><img class="image-element__img" alt="" src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNTY2Mjk2MS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY3NDQxNTU0Mn0.jaHwrlieZPHEQPfNbeMlQt_azrNlei9PmUa7-5xAvSQ/img.png?width=500&height=77"></a><!-- End User Code --></div><div class="raw-story-investigates" id="sTop_Bar_0_0_8_0_0_15_0_0_3"><!-- User Code --><a href="/st/raw_story_investigates" target="_self"><img class="image-element__img" alt="" src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNTY2Mjk3MC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTYzOTE5NTIyOH0.j-uT9-VmyNbickVg4hmkA6BFhDw43DnmSwid52l-UB8/img.png?width=166&height=60"></a><!-- End User Code --></div><div class="search-container" id="sTop_Bar_0_0_8_0_0_15_0_0_4"><!-- User Code --><a class="search-form__open js-toggle"><i class="fa fa-search"></i></a><!-- End User Code --></div></div></div></div><div class="sticky-top-ad-container" id="sTop_Bar_0_0_8_0_0_16"><!-- User Code -->
        
        
        
        <!-- <div class='sticky-top-ad'><div class="proper-ad-unit"><div id="proper-ad-rawstory_story_page_top"></div></div></div> --><!-- End User Code --></div><div class="fake-topbar" id="sTop_Bar_0_0_8_0_0_17"></div><!-- User Code --><div class="shadow-overlay"></div><div id="mySidenav" class="sidenav"><div class="closebtn"><span class="menu-line-1"></span><span class="menu-line-2"></span></div><div class="search-logo"><a href="/" class="search-logo"><img type="lazy-image" data-runner-src="https://assets.rbl.ms/23278157/origin.jpg" image_type="jpg" image_width="405" image_id="23278157" image_height="65" image_filename="ezgif.com-webp-to-jpg.jpg" style_image_all_default_height="30px"  style_image_all_default_width="138px" link_href="/" link_target="_self"/></a></div><ul><li><a href="/">Home</a></li><li><a href="https://www.teepublic.com/stores/raw-story-store?ref_id=9578&amp;sort=popular">New: Shop to Support Independent Journalism</a></li><li><a href="/presidential-campaign-issues/">We Have Issues</a></li><li><a href="/trump-news/">Trump</a></li><li><a class="link" href="/nation/">U.S. News</a></li><li><a href="/all-video/">Video</a></li><!--<li><a onclick="(function(){window.admiral('show','transact.login')})()">Ad-Free Login</a></li>--><li><a id="piano_login_button_sidenav" class="list__item ad-free-link top-nav">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</a></li></ul></div><!-- End User Code --><!-- User Code --><div class="search-form" ><form action="/search/"><input placeholder="Search" type="text" name="q" class="search-form__text-input"></form><a class="close-button"><span class="cross"></span></a></div><!-- End User Code --><div class="" id="sTop_Bar_0_0_8_0_0_25"></div><span class="js-brick-description hidden" data-name="InfoBar"></span><!-- User Code --><div id='piano-infobar-container'></div><!-- End User Code --><span class="js-brick-description hidden" data-name="chartbeat"></span><when test="541952329 not in post.sections "><!-- User Code -->
    
      
      
      
      <!-- NOT A SURVEY --><!-- End User Code --></when><!-- User Code --><script>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</script><!-- End User Code --><!-- User Code --><script> var sponsoredLayout = false;  </script><!-- End User Code --><!-- User Code --><div class="proper-ad-unit desktop-only no-gray"><div id="proper-ad-rawstory_story_page_top"></div></div><!-- End User Code --><span class="js-brick-description hidden" data-name="Top-btn"></span><!-- User Code --><button onclick="topFunction()" class="go-top-btn" id="myBtn" title="Go to top"><i class="fa fa-angle-up fa-3"></i></button><style>
  #myBtn {
    position: fixed; 
    top: 50%; 
    right: 0; 
    z-index: 99; 
    background: rgba(0,0,0,.3);
    border-top: 1px solid #fff;
    border-left: 1px solid #fff;
    border-bottom: 1px solid #fff;
    border-right: 1px solid #fff;
    color: #fff;
    outline: none; /* Remove outline */
    cursor: pointer;
    font-size: 40px; 
    width: 50px;
    height: 50px;
    opacity: 1;
    -webkit-transition: all .3s;
    transition: all .3s;
    -webkit-transform: translate3d(100px,0,0);
    -moz-transform: translate3d(100px,0,0);
    -ms-transform: translate3d(100px,0,0);
    -o-transform: translate3d(100px,0,0);
    transform: translate3d(100px,0,0);
  }
   #myBtn i {
     position: absolute;
     left: 12px;
     top: 1px;
  }

  #myBtn:hover {
    background-color: #df1f27; 
    color: black;
  }
  #myBtn.visible {
  -webkit-transform: translate3d(0,0,0); 
    -moz-transform: translate3d(0,0,0);
    -ms-transform: translate3d(0,0,0);
    -o-transform: translate3d(0,0,0);
     transform: translate3d(0,0,0);
  }
</style><script>
  //Get the button:
  mybutton = document.getElementById("myBtn");

  // When the user scrolls down 20px from the top of the document, show the button
  window.onscroll = function() {
    if(!window.document.documentMode){
      scrollFunction();
    }
  };

  function scrollFunction() {
  if(window.pageYOffset>window.innerHeight){
  mybutton.classList.add("visible")
  }
  else {
   mybutton.classList.remove("visible")
  }
  }

  // When the user clicks on the button, scroll to the top of the document
  function topFunction() {
    window.scrollTo({top: 0, behavior: 'smooth'});
} 
</script><!-- End User Code --><div id="sPost_0_0_4_0_0_5_2_5" class="content-wrap row-wrapper clearfix ">
    <div class="row px20">
        

<div id="sPost_0_0_4_0_0_5_2_5_0" class=" col sm-mb-2 md-mb-4 s12 m12 l11">
    <div class="mb-2 post-head " id="sPost_0_0_4_0_0_5_2_5_0_0"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="None"
        data-format="posts-custom"
        data-source="current_post"
        data-source-type="current_post"
        data-source-unique="true"
        data-section-id=""
        data-is-reordable="false"
        data-using-stickers="false"
        data-has-more="false"

    
        data-attr-all_share_buttons="Facebook,Twitter,Flipboard,CopyLink,Email,FacebookMessenger,Linkedin,GooglePlus,Pinterest,Whatsapp,Reddit,Separator,Tumblr,SMS,Slack"
        data-attr-layout_CopyLink="active"
        data-attr-all_element_order="headline,author,date,post_shares,body,section,community_name,subheadline,badges,badges_sponsored,photo_credit,photo_caption,snark_line,page_views,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,date_modified,custom_field_smart_news_feed_headline,custom_field_Send-alternative-headline-to-smartnews,custom_field_is_survey_post,custom_field_survey_text_italic,custom_field_survey_text_red,product_prices,product_vendor,product_buy_link"
        data-attr-layout_all_date_format="%B %d, %Y"
        data-attr-show_more_button_text="Continue Reading"
        data-attr-layout_Whatsapp="inactive"
        data-attr-layout_Separator="inactive"
        data-attr-layout_Slack="inactive"
        data-attr-layout_all_subheadline_tag="h4"
        data-attr-source_unique="true"
        data-attr-data-rm-device-video-crops="true"
        data-attr-section_url=""
        data-attr-layout_mobile_image_crop="16x9"
        data-attr-layout_Flipboard="active"
        data-attr-v="2"
        data-attr-data-rm-advanced="true"
        data-attr-source_url="current_post"
        data-attr-layout_Linkedin="inactive"
        data-attr-without_current="true"
        data-attr-layout_date="top"
        data-attr-layout_remove_image="true"
        data-attr-layout_post_shares="top"
        data-attr-layout_Pinterest="inactive"
        data-attr-layout_author="top"
        data-attr-show_full_post_body="true"
        data-attr-posts_id="sPost_0_0_4_0_0_5_2_5_0_0"
        data-attr-is_current_post="true"
        data-attr-data-rm-device-crops="true"
        data-attr-layout_Reddit="inactive"
        data-attr-limit="1"
        data-attr-layout_all_show_video="true"
        data-attr-format="posts-custom"
        data-attr-layout_Tumblr="inactive"
        data-attr-layout_SMS="inactive"
        data-attr-layout_all_image_crop="3x2"
        data-attr-element_classes="post-head "
        data-attr-node_id="/root/blocks/block[post]/abtests/abtest[1]/choose[2]/otherwise/row/column[1]/posts-"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_Email="active"
        data-attr-layout_headline="top"
        data-attr-layout_quality="2"><div class="posts-wrapper clearfix">
            
                
                <div class="widget post-partial"
                
                data-category="Latest Headlines">
<article 
    elid="2654381056" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654381056" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><h1 class="widget__headline h1">
    <a class="widget__headline-text custom-post-headline" href="https://www.rawstory.com/wendy-rogers-arizona/"  aria-label="Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials" data-type="text">
        Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials
    </a>
</h1>


<div class="social-author clearfix">
    

    
        
    <div class="social-author__avatar image" >
             <div class="cover-all image" style='background-image: url("https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDgzNjE4NC9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY3NDk3MTAxNH0.f7RvUMoSVsGINpDf-_SIqlRaLaHPZ0v4Ax0Qhdb2yJA/image.gif?width=210")'></div>
        </div>
        <a class="social-author__name" href="https://www.rawstory.com/u/brad_reed" data-type="text">Brad Reed</a>
        
</div>
<div class="social-date">
        <span class="social-date__text">August 02, 2021</span>
    </div><div class="widget__shares share-panel">
    <!-- FACEBOOK -->
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rawstory.com%2Fwendy-rogers-arizona%2F%3Fxrs%3DRebelMouse_fb%26ts%3D1627947567" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- TWITTER -->
<a href="https://twitter.com/intent/tweet?url=https://www.rawstory.com/wendy-rogers-arizona/&amp;text=Trump-loving%20Arizona%20state%20senator%20pushes%20for%20mass%20arrests%20of%20Maricopa%20County%20election%20officials&amp;" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FLIPBOARD -->
<a href="https://share.flipboard.com/bookmarklet/popout?v=2&url=https://www.rawstory.com/wendy-rogers-arizona/" class="share share-popup share-flipboard" data-track-share="Flipboard" rel="noopener noreferrer" aria-label="Share on Flipboard">
<svg aria-hidden="true" style="border-radius:45%" aria-hidden="true" role="img" viewBox="15 40 430 430"><path fill="currentColor" d="M0 32v448h448V32H0zm358.4 179.2h-89.6v89.6h-89.6v89.6H89.6V121.6h268.8v89.6z"></path></svg></a><!-- COPY LINK -->
<a href="https://www.rawstory.com/wendy-rogers-arizona/" data-clipboard-text="https://www.rawstory.com/wendy-rogers-arizona/" class="share share-copy-link" title="Copy this link to clipboard">
  <i class="icons-share" style="width: 60%">
  <svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i>
</a><!-- EMAIL -->
<a href="mailto:?subject=Trump-loving%20Arizona%20state%20senator%20pushes%20for%20mass%20arrests%20of%20Maricopa%20County%20election%20officials&amp;body=https://www.rawstory.com/wendy-rogers-arizona/" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a>
</div></div><div class="widget__head">
                            
                                
                            <div class="widget__image crop-3x2"
                                    role="img"
                                    aria-label="Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials"
                                    style="display: none"
                                    data-type="image"
                            ></div>
                            
                </div></div></div>
    
    
<script type="application/json" id="post-context-2654381056">
    {"customDimensions": {"7":"Brad Reed","8":"hot-off-the-wires","10":"08/02/2021","13":2654381056,"14":true,"15":false}, "post": {"providerId": 0, "sections": [0, 532450088, 537910665, 504781448, 502613554, 535969657], "buckets": [], "authors": [20272778]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div>
</div>



<div id="sPost_0_0_4_0_0_5_2_5_1" class="content-colum col sm-mb-2 md-mb-4 s12 m12 l8">
    <div class="mb-2 post-head post-body article-body" id="sPost_0_0_4_0_0_5_2_5_1_0"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="None"
        data-format="posts-custom"
        data-source="current_post"
        data-source-type="current_post"
        data-source-unique="true"
        data-section-id=""
        data-is-reordable="false"
        data-using-stickers="false"
        data-has-more="false"

    
        data-attr-use_tag_image_for_lead_media="true"
        data-attr-all_share_buttons="Facebook,Twitter,Flipboard,CopyLink,Email,FacebookMessenger,Linkedin,GooglePlus,Pinterest,Whatsapp,Reddit,Separator,Tumblr,SMS,Slack"
        data-attr-layout_CopyLink="active"
        data-attr-all_element_order="photo_credit,body,post_shares,author,date,section,community_name,headline,badges,badges_sponsored,subheadline,photo_caption,snark_line,page_views,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,date_modified,custom_field_smart_news_feed_headline,custom_field_Send-alternative-headline-to-smartnews,custom_field_is_survey_post,custom_field_survey_text_italic,custom_field_survey_text_red,product_prices,product_vendor,product_buy_link"
        data-attr-layout_all_date_format="%B %d, %Y"
        data-attr-layout_Whatsapp="inactive"
        data-attr-layout_Separator="inactive"
        data-attr-layout_Slack="inactive"
        data-attr-layout_all_subheadline_tag="h4"
        data-attr-source_unique="true"
        data-attr-section_url=""
        data-attr-layout_Flipboard="active"
        data-attr-data-rm-advanced="true"
        data-attr-show_more_button_text="Continue Reading"
        data-attr-layout_photo_credit="bottom"
        data-attr-layout_Linkedin="inactive"
        data-attr-source_url="current_post"
        data-attr-without_current="true"
        data-attr-layout_post_shares="bottom"
        data-attr-layout_Pinterest="inactive"
        data-attr-show_full_post_body="true"
        data-attr-posts_id="sPost_0_0_4_0_0_5_2_5_1_0"
        data-attr-is_current_post="true"
        data-attr-data-rm-device-crops="true"
        data-attr-layout_Reddit="inactive"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-layout_all_sections="bottom"
        data-attr-layout_body="bottom"
        data-attr-format="posts-custom"
        data-attr-layout_Tumblr="inactive"
        data-attr-layout_SMS="inactive"
        data-attr-layout_all_image_crop="original"
        data-attr-element_classes="post-head post-body article-body"
        data-attr-node_id="/root/blocks/block[post]/abtests/abtest[1]/choose[2]/otherwise/row/column[2]/posts[1]-"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_Email="active"
        data-attr-layout_quality="5"
        data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix">
            
                
                <div class="widget post-partial"
                
                data-category="Latest Headlines">
<article 
    elid="2654381056" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654381056" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__head">
                            
                                
                            <img
                                        role="img"
                                        
                                        alt="Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials"
                                        aria-label="Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials"
                                        src="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMzg0MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NTExMjUyMH0.9285uted0XHXZND3qB3e2gdAH_sJJwNi9ZipuOukFuc/image.jpg?width=1200&amp;height=680"
                                        
                                        
                                        style="object-fit: cover;"
                                        
                                        class="rm-lazyloadable-image"
                                        width="980"
                                        height="556"
                                    />
                </div><div class="widget__body clearfix sm-mt-1"><div class="photo-credit">
        Fox News screenshot
    </div><span class="js-scroll-trigger" data-target="body" data-triggers="render-rebelbar" data-toggle-class="with-floating-shares"></span>
<div id="utm_campaign"></div><div class="body js-expandable clearfix js-listicle-body  css-listicle-body-2654381056"
        ><div class="body-description"><p>Trump-loving Arizona State Sen. Wendy Rogers lashed out at the Maricopa County Board of Supervisors after it refused to comply the Arizona Republicans' demands for more information related to the Trump-backed "audit" of the 2020 election.</p><p>After Jack Sellers, the chair of the board, wrote a snide letter mocking the Arizona Republicans for living in "never-never land," Rogers took to Twitter and pushed for mass arrests of the entire board.</p><p>"I would like to know if we have enough solitary confinement cells in Arizona available for the entire Maricopa Board of Supervisors and the execs at the fraud machine company," she wrote. "We are going to need a lot."</p><p>In a followup tweet, Rogers mused about potentially charging the Maricopa County officials with "treason."</p><p>"Should stolen elections be considered treason?" she asked.</p><p>In fact, even though stealing an election is illegal, it is not treason because it does not involve giving aid and comfort to a foreign nation at war with the United States.</p><p>Additionally, the 2020 presidential election was not stolen and President Joe Biden was certified as the winner back in January.</p><p><br/></p>
<p><br/></p>
<div class="rm-shortcode" data-rm-shortcode-id="1f075ebe64d8bb535e9392911d3c215b" id="0c952">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 66%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 32%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422326991064293380">
<div style="margin:1em 0">Should stolen elections be considered treason?</div> — Wendy Rogers (@Wendy Rogers)
                        <a href="https://twitter.com/WendyRogersAZ/statuses/1422326991064293380">1627944154.0</a>
</blockquote>
</div>
</div>
</div>
</div>
        

        

    </div>



<span class=""
    data-elid="2654381056"
    data-post-url="https://www.rawstory.com/wendy-rogers-arizona/"
    
        data-authors="Brad Reed"
    
    
        data-headline="Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials"
    >
</span>
<div class="widget__shares share-panel">
    <!-- FACEBOOK -->
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rawstory.com%2Fwendy-rogers-arizona%2F%3Fxrs%3DRebelMouse_fb%26ts%3D1627947567" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- TWITTER -->
<a href="https://twitter.com/intent/tweet?url=https://www.rawstory.com/wendy-rogers-arizona/&amp;text=Trump-loving%20Arizona%20state%20senator%20pushes%20for%20mass%20arrests%20of%20Maricopa%20County%20election%20officials&amp;" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FLIPBOARD -->
<a href="https://share.flipboard.com/bookmarklet/popout?v=2&url=https://www.rawstory.com/wendy-rogers-arizona/" class="share share-popup share-flipboard" data-track-share="Flipboard" rel="noopener noreferrer" aria-label="Share on Flipboard">
<svg aria-hidden="true" style="border-radius:45%" aria-hidden="true" role="img" viewBox="15 40 430 430"><path fill="currentColor" d="M0 32v448h448V32H0zm358.4 179.2h-89.6v89.6h-89.6v89.6H89.6V121.6h268.8v89.6z"></path></svg></a><!-- COPY LINK -->
<a href="https://www.rawstory.com/wendy-rogers-arizona/" data-clipboard-text="https://www.rawstory.com/wendy-rogers-arizona/" class="share share-copy-link" title="Copy this link to clipboard">
  <i class="icons-share" style="width: 60%">
  <svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i>
</a><!-- EMAIL -->
<a href="mailto:?subject=Trump-loving%20Arizona%20state%20senator%20pushes%20for%20mass%20arrests%20of%20Maricopa%20County%20election%20officials&amp;body=https://www.rawstory.com/wendy-rogers-arizona/" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a>
</div>
               
        <div class="all-related-sections">
                <a href="https://www.rawstory.com/smartnews/">SmartNews</a>
            </div></div></div></div>
    
    
<script type="application/json" id="post-context-2654381056">
    {"customDimensions": {"7":"Brad Reed","8":"hot-off-the-wires","10":"08/02/2021","13":2654381056,"14":true,"15":false}, "post": {"providerId": 0, "sections": [0, 532450088, 537910665, 504781448, 502613554, 535969657], "buckets": [], "authors": [20272778]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div><!-- User Code --><script>
//window.postContent=document.querySelectorAll(".article-body .body-description > *:not(hr)");

/* Script to dedup featured image on nordot posts */

console.log( 'Post.provider_id = 0' );
  
if(0==25){ 
  	console.log( 'deduping nordot image' );
    let lead_image=document.querySelector('.post-head .widget__img img').src.split("/img."); 
    let body_image=document.querySelector('.post-head .body img').src?document.querySelector('.post-head .body img').src.split("/img."):document.querySelector('.post-head .body img').getAttribute('data-runner-src').split("/img."); 
    if(lead_image[0]=body_image[0]){ 
        document.querySelector('.post-head .body img').remove(); 
    }
} 
  
/* Script to insert ig red incontent appeal */
  
window.postContent = document.querySelectorAll('.article-body .body-description > *:not(hr):not(.story_page_before_content):not(.proper-ad-unit):not(.story_page_incontent_ig)');
  
if ( postContent[2] ) {
	/*
    postContent[2].insertAdjacentHTML('afterend',`<div class="story_page_incontent_instagram_container story_page_incontent_ig"><div><a style="color:#dd3030;text-decoration:none" id="incontent_ig_login_link" href="https://www.rawstory.com/podcast/" target="_blank">Chris Matthews talks to Raw Story: Who would you bet on in 2024, Trump or Kamala?</a></div></div>`);
    */
}
</script><!-- End User Code --><!-- User Code --><div class="report-content">
Report typos and corrections to: <a href="mailto:corrections@rawstory.com">corrections@rawstory.com</a>.
</div><!-- End User Code --><!-- User Code --><div id="story_page_post-content_regular-site"></div><style>
@media only screen and (max-width: 599px) {
  #story_page_post-content_regular-site {
    display: none;
  }
}
</style><!-- End User Code --><!-- User Code --><div id='mobile_post_article'></div><style>
@media only screen and (min-width: 599px) {
  #mobile_post_article {
    display: none;
  }
}
</style><!-- End User Code --><!-- User Code --><!-- <script>(function(t,e,s,o){var n,c,l;t.SMCX=t.SMCX||[],e.getElementById(o)||(n=e.getElementsByTagName(s),c=n[n.length-1],l=e.createElement(s),l.type="text/javascript",l.async=!0,l.id=o,l.src="https://widget.surveymonkey.com/collect/website/js/tRaiETqnLgj758hTBazgd_2Fhc5Qvscs_2BJX2p679sLTibXRkFwlrjZKflL1fUQ0jdA.js",c.parentNode.insertBefore(l,c))})(window,document,"script","smcx-sdk");</script> --><!-- End User Code --><!-- User Code --><div class="connatix-holder"><div id="3c873ced6dcf4282952e7744badecace"></div></div><!-- End User Code --><div class="" id="sPost_0_0_4_0_0_5_2_5_1_9"></div><div class="" id="sPost_0_0_4_0_0_5_2_5_1_10"><!-- User Code --><div id="lightbox-inline-form-3574e8d4-8014-4e8b-a842-008a62591036"></div><div id="lightbox-inline-form-2aed73c1-91cf-4be7-a1f1-1a6339b91b35"></div> <!-- End User Code --></div><div class="load_disqus_link" id="sPost_0_0_4_0_0_5_2_5_1_11_0_0"><!-- User Code -->
              
              
                        
                        
                        
                        
              
              
                  
                  <!--a href="https://www.rawstory.com/wendy-rogers-arizona/?comments=disqus" title="Load Comments" rel="nofollow">Read Comments - Join the Discussion</a--><a href="#comments_section_start" rel="noopener" class="read-comments">READ COMMENTS - JOIN THE DISCUSSION</a><!-- End User Code --></div><span class="js-brick-description hidden" data-name="survey_shared_element"></span><div class="mb-2 survey_post_promo" id="ssurvey_shared_element_0_0_15_0_0_0"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_1"
        data-format="posts-custom"
        data-source="frontpage_parent_site_polls"
        data-source-type="page"
        data-source-unique="true"
        data-section-id="541952329"
        data-is-reordable="true"
        data-using-stickers="true"
        data-has-more="true"

    
        data-attr-element_classes="survey_post_promo"
        data-attr-posts_id="ssurvey_shared_element_0_0_15_0_0_0"
        data-attr-source_site="parent_site"
        data-attr-layout_headline="bottom"
        data-attr-format="posts-custom"
        data-attr-all_element_order="headline,subheadline,section,author,community_name,date,date_modified,badges,badges_sponsored,photo_credit,photo_caption,body,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,custom_field_is_survey_post,custom_field_survey_text_italic,custom_field_smart_news_feed_headline,custom_field_Send-alternative-headline-to-smartnews,custom_field_survey_text_red,product_prices,product_vendor,product_buy_link"
        data-attr-data-rm-advanced="true"
        data-attr-source_url="polls"
        data-attr-section_url="polls"
        data-attr-layout_all_headline_tag="h2"
        data-attr-layout_all_image_crop="original"
        data-attr-layout_quality="1"
        data-attr-v="2"
        data-attr-limit="1"
        data-attr-node_id="/root/blocks/block[survey_shared_element]/abtests/abtest[1]/posts-"
        data-attr-without_current="true"
        data-attr-source_unique="true"><div class="posts-wrapper clearfix">
            
                
                <div class="widget"
                 elid="2654253980"
                data-category="polls">
<article 
    elid="2654253980" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654253980" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__head"><a href="https://www.rawstory.com/trump-influence-poll/"  aria-label="Is Trump&#39;s influence diminishing?">
                            
                            <div class="widget__image crop-1524x864"
                                    role="img"
                                    aria-label="Is Trump&#39;s influence diminishing?"
                                        
                                    data-runner-img-hd="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA4NDQ1MS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY3NzI5OTk1M30.FvmkTh9Nd_DUAtqciS-Fg7OgENzNTNd-V1cArHCv2rg/image.png?width=1200&amp;height=680"
                                    data-runner-img-md="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA4NDQ1MS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY3NzI5OTk1M30.FvmkTh9Nd_DUAtqciS-Fg7OgENzNTNd-V1cArHCv2rg/image.png?width=600&amp;height=340"
                                    data-runner-img-sd="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA4NDQ1MS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY3NzI5OTk1M30.FvmkTh9Nd_DUAtqciS-Fg7OgENzNTNd-V1cArHCv2rg/image.png?width=300&amp;height=170"
                                    data-runner-style='padding-bottom: 56.6929133858%;'
                                    style='padding-bottom: 56.6929133858%;'
                                        data-type="image"
                            ><div class="lazyload-placeholder">
                                    <div class="runner-spinner">
                                      <svg class="runner-spinner-circular" viewBox="25 25 50 50">
                                        <circle class="runner-spinner-path" cx="50" cy="50" r="20" fill="none" stroke-width="3" stroke-miterlimit="10"/>
                                      </svg>
                                    </div>
                                </div></div>
                            </a>
                </div><div class="widget__body clearfix sm-mt-1"><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://www.rawstory.com/trump-influence-poll/"  aria-label="Is Trump&#39;s influence diminishing?" data-type="text">
        Is Trump&#39;s influence diminishing?
    </a>
</h2></div></div></div>
    
    
<script type="application/json" id="post-context-2654253980">
    {"customDimensions": {"7":"Elias Rawstory","8":"polls","10":"07/29/2021","13":2654253980,"14":true,"15":false}, "post": {"providerId": 0, "sections": [541952329], "buckets": [], "authors": [20374338]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div><!-- User Code --><div id='rc-widget-d9572e' data-rc-widget data-widget-host='habitat' data-endpoint='//trends.revcontent.com' data-widget-id='112075'></div><!-- End User Code --><span class="js-brick-description hidden" data-name="pink_appeal_box"></span><div class="paypal" id="spink_appeal_box_0_0_10_0_0_0"><!-- User Code --><div class='below-content-appeal proper-ad-unit' style='background: #fff; border: 5px solid red; padding: 10px; margin: 0 auto 10px auto; width: 100%; text-align: left;'><div class='message'></div><div class='form'></div></div><!-- End User Code --></div><!-- User Code -->
                    
                    
                    
          
          
              
              <!-- MGID - 3x2 Under-Article - Composite Start --><div class="mgid_3x2"><div id="M687751ScriptRootC1087714"></div></div><!-- MGID - 3x2 Under-Article - Composite End --><!-- End User Code --><div class="mb-2 post-head scroll-post" id="sPost_0_0_4_0_0_5_2_5_1_18"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_2"
        data-format="posts-custom"
        data-source="current_page"
        data-source-type="page"
        data-source-unique="true"
        data-section-id="0"
        data-is-reordable="true"
        data-using-stickers="true"
        data-has-more="true"

    
        data-attr-source="current_page"
        data-attr-all_share_buttons="Facebook,Twitter,Flipboard,CopyLink,Email,Linkedin,GooglePlus,Pinterest,Whatsapp,Reddit,Separator,Tumblr,SMS,Slack"
        data-attr-use_smart_keep_reading="true"
        data-attr-all_element_order="headline,author,date,body,section,community_name,subheadline,badges,badges_sponsored,photo_credit,photo_caption,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,date_modified,custom_field_smart_news_feed_headline,custom_field_Send-alternative-headline-to-smartnews,custom_field_is_survey_post,custom_field_survey_text_italic,custom_field_survey_text_red,product_prices,product_vendor,product_buy_link"
        data-attr-layout_all_date_format="%B %d, %Y"
        data-attr-show_more_button_text="CONTINUE READING"
        data-attr-layout_Whatsapp="inactive"
        data-attr-layout_Separator="inactive"
        data-attr-layout_Slack="inactive"
        data-attr-layout_all_subheadline_tag="h4"
        data-attr-source_unique="true"
        data-attr-section_url=""
        data-attr-layout_date="top"
        data-attr-data-rm-advanced="true"
        data-attr-source_url="current_page"
        data-attr-layout_Linkedin="inactive"
        data-attr-without_current="true"
        data-attr-layout_all_headline_tag="h2"
        data-attr-layout_Pinterest="inactive"
        data-attr-layout_author="top"
        data-attr-posts_id="sPost_0_0_4_0_0_5_2_5_1_18"
        data-attr-layout_Reddit="inactive"
        data-attr-limit="2"
        data-attr-v="2"
        data-attr-layout_body="bottom"
        data-attr-layout_headline="top"
        data-attr-format="posts-custom"
        data-attr-layout_Tumblr="inactive"
        data-attr-layout_SMS="inactive"
        data-attr-layout_all_image_crop="original"
        data-attr-element_classes="post-head scroll-post"
        data-attr-node_id="/root/blocks/block[post]/abtests/abtest[1]/choose[2]/otherwise/row/column[2]/posts[2]-"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_Email="active"
        data-attr-source_id="current_page"
        data-attr-layout_quality="5"
        data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix">
            
                
                <div class="widget"
                 elid="2654379262"
                data-category="Latest Headlines">
<article 
    elid="2654379262" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654379262" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://www.rawstory.com/mount-trumpmore-rushmore/"  aria-label="Texas sculptor creates &#39;Mount Trumpmore&#39; monument -- and whines after former student trashes it" data-type="text">
        Texas sculptor creates &#39;Mount Trumpmore&#39; monument -- and whines after former student trashes it
    </a>
</h2>


<div class="social-author clearfix">
    

    
        
    <div class="social-author__avatar image" >
             <div class="cover-all image" style='background-image: url("https://rawstory.com/res/avatars/default")'></div>
        </div>
        <a class="social-author__name" href="https://www.rawstory.com/u/bob_brigham" data-type="text">Bob Brigham</a>
        
</div>
<div class="social-date">
        <span class="social-date__text">August 02, 2021</span>
    </div></div><div class="widget__head"><a href="https://www.rawstory.com/mount-trumpmore-rushmore/"  aria-label="Texas sculptor creates &#39;Mount Trumpmore&#39; monument -- and whines after former student trashes it">
                            
                            <div class="widget__image crop-800x450"
                                    role="img"
                                    aria-label="Texas sculptor creates &#39;Mount Trumpmore&#39; monument -- and whines after former student trashes it"
                                        
                                    data-runner-img-hd="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMjg0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY0NTc0ODY4MH0.V6GakA28etAkCReNApLVXR7ccNYhHvYF2uMKa0Vk7GA/image.png?width=1200&amp;height=675"
                                    data-runner-img-md="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMjg0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY0NTc0ODY4MH0.V6GakA28etAkCReNApLVXR7ccNYhHvYF2uMKa0Vk7GA/image.png?width=600&amp;height=337"
                                    data-runner-img-sd="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMjg0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY0NTc0ODY4MH0.V6GakA28etAkCReNApLVXR7ccNYhHvYF2uMKa0Vk7GA/image.png?width=300&amp;height=168"
                                    data-runner-style='padding-bottom: 56.25%;'
                                    style='padding-bottom: 56.25%;'
                                        data-type="image"
                            ><div class="lazyload-placeholder">
                                    <div class="runner-spinner">
                                      <svg class="runner-spinner-circular" viewBox="25 25 50 50">
                                        <circle class="runner-spinner-path" cx="50" cy="50" r="20" fill="none" stroke-width="3" stroke-miterlimit="10"/>
                                      </svg>
                                    </div>
                                </div></div>
                            </a>
                </div><div class="widget__body clearfix sm-mt-1"><div class="body js-expandable clearfix js-listicle-body  css-listicle-body-2654379262"
        ><div class="body-description"><div class="widget__brief"><p>Donald Trump's face would be carved into the Mount Rushmore National Memorial in South Dakota if one Texas man has his way.</p><p>The "New Tang Dynasty" (NTD) evening news <a href="https://www.ntd.com/texas-sculptor-makes-mount-trumpmore_651705.html" target="_blank">interviewed</a> Trace Guthrie, a sculptor who sells <a href="http://www.traceguthrie.com/mount-trumpmore/mount-trumpmore-3" target="_blank">$250 clay sculptures</a> of Trump in between Theodore Roosevelt and Abraham Lincoln that he calls, "Mount Trumpmore."</p></div>
            <div class="content-container"></div>
            <div class="js-appear-on-expand"><template><p>Even though it has been <a href="https://www.nytimes.com/interactive/2018/10/02/us/politics/donald-trump-tax-schemes-fred-trump.html?mtrref=undefined&amp;gwh=D01F4CC474998AD5C4AC2052B1D385C3&amp;gwt=pay&amp;assetType=PAYWALL" target="_blank">reported</a> that the former president was given at least $413 million from his father, Guthrie praised the former reality TV star as a man of the people.</p><p>"The guy is, they say, a billionaire, but he's got a blue collar on him. He actually gets out there with those construction people building his buildings, and he knows them," Guthrie argued.</p><p>Guthries complained, however, about the criticism he received for his statue from a former student who wrote him a message bashing the former president.</p><p>"She said, 'Trump has killed half a million people with COVID!'" he said. "And the only thing I'm wondering is, where did you get that."</p><p>More than 600,000 Americans have died from COVID-19. While Trump is not responsible for all of them, he repeatedly downplayed the pandemic by comparing it to the flu while also recommending unproven treatments for the disease such as hydroxychloroquine.</p><p>Trump also falsely told followers they had "nothing" to fear from the virus after he got out of the hospital after being treated for the disease last fall.</p><div class="rm-shortcode" data-rm-shortcode-id="6f76e746f10055f62a5f1a4e071f0ba7" id="c6ada">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 140%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 104%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422317564735238153">
<div style="margin:1em 0">A Texas sculptor has created a model to scale-up so Trump can be added to Mt. Rushmore. “The guy is a billionaire,… https://t.co/NjFrKEKCfY</div> — Ron Filipkowski (@Ron Filipkowski)
                        <a href="https://twitter.com/RonFilipkowski/statuses/1422317564735238153">1627941907.0</a>
</blockquote>
</div>
</div>
</div></template></div>
            <div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds">
                <span class="show-more js-expand">CONTINUE READING</span>
                <span class="show-less js-contract">Show less</span>
            </div></div>
        

        

    </div>

<span class=""
    data-elid="2654379262"
    data-post-url="https://www.rawstory.com/mount-trumpmore-rushmore/"
    
        data-authors="Bob Brigham"
    
    
        data-headline="Texas sculptor creates &#39;Mount Trumpmore&#39; monument -- and whines after former student trashes it"
    >
</span>
</div></div></div>
    
    
<script type="application/json" id="post-context-2654379262">
    {"customDimensions": {"7":"Bob Brigham","8":"hot-off-the-wires","10":"08/02/2021","13":2654379262,"14":false,"15":false}, "post": {"providerId": 0, "sections": [0, 504781448, 537910665, 532450088, 502613554, 506149267, 506149270, 535969657, 506149276], "buckets": [], "authors": [20272805]} }
</script>
</article>
                </div>
            
                
                <div class="widget"
                 elid="2654378836"
                data-category="Latest Headlines">
<article 
    elid="2654378836" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654378836" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://www.rawstory.com/trump-tax-returns-2654378836/"  aria-label="&#39;He&#39;s hiding something&#39;: Trump mocked for desperate last-minute bid to stop Congress from getting his taxes" data-type="text">
        &#39;He&#39;s hiding something&#39;: Trump mocked for desperate last-minute bid to stop Congress from getting his taxes
    </a>
</h2>


<div class="social-author clearfix">
    

    
        
    <div class="social-author__avatar image" >
             <div class="cover-all image" style='background-image: url("https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDgzNjE4Ny9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY2NjcxMDM5MH0.XitgewG_YSe3rlRzbKsvDmJ8lqOqcDxP-J-6rlpbt-M/image.gif?width=210")'></div>
        </div>
        <a class="social-author__name" href="https://www.rawstory.com/u/matthew_chapman" data-type="text">Matthew Chapman</a>
        
</div>
<div class="social-date">
        <span class="social-date__text">August 02, 2021</span>
    </div></div><div class="widget__head"><a href="https://www.rawstory.com/trump-tax-returns-2654378836/"  aria-label="&#39;He&#39;s hiding something&#39;: Trump mocked for desperate last-minute bid to stop Congress from getting his taxes">
                            
                            <div class="widget__image crop-980x551"
                                    role="img"
                                    aria-label="&#39;He&#39;s hiding something&#39;: Trump mocked for desperate last-minute bid to stop Congress from getting his taxes"
                                        
                                    data-runner-img-hd="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMTg1OC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzOTg3MzA1OH0.4dVA9Z_exEiD18bWv9PZFKmOunvMYHZAmPwALsM7bZo/image.jpg?width=1200&amp;height=674"
                                    data-runner-img-md="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMTg1OC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzOTg3MzA1OH0.4dVA9Z_exEiD18bWv9PZFKmOunvMYHZAmPwALsM7bZo/image.jpg?width=600&amp;height=337"
                                    data-runner-img-sd="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMTg1OC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzOTg3MzA1OH0.4dVA9Z_exEiD18bWv9PZFKmOunvMYHZAmPwALsM7bZo/image.jpg?width=300&amp;height=168"
                                    data-runner-style='padding-bottom: 56.2244897959%;'
                                    style='padding-bottom: 56.2244897959%;'
                                        data-type="image"
                            ><div class="lazyload-placeholder">
                                    <div class="runner-spinner">
                                      <svg class="runner-spinner-circular" viewBox="25 25 50 50">
                                        <circle class="runner-spinner-path" cx="50" cy="50" r="20" fill="none" stroke-width="3" stroke-miterlimit="10"/>
                                      </svg>
                                    </div>
                                </div></div>
                            </a>
                </div><div class="widget__body clearfix sm-mt-1"><div class="body js-expandable clearfix js-listicle-body  css-listicle-body-2654378836"
        ><div class="body-description"><div class="widget__brief"><p>On Monday, an attorney for former President Donald Trump <a href="https://www.rawstory.com/trump-tax-returns-congress/?utm_source=push_notifications" target="_blank">announced</a> the intent to fight the new ruling from the Justice Department that the former president's tax returns must be handed over to investigators in Congress.</p><p>The president's ongoing furious refusal to allow others to see his tax returns, which were already handed over to the Manhattan District Attorney after a years-long legal battle that made its way <a href="https://www.reuters.com/article/us-usa-court-trump-taxes/u-s-supreme-court-sets-the-stage-for-release-of-trump-tax-returns-idUSKBN2AM1MN" target="_blank">up to the Supreme Court</a>, earned a fresh wave of mockery from commenters on social media — some of whom noted Trump said he'd make his tax returns public at the very start of his 2015 presidential campaign.</p></div>
            <div class="content-container"></div>
            <div class="js-appear-on-expand"><template><div class="rm-shortcode" data-rm-shortcode-id="aae3c7490a0643c8da27674a285d49f7" id="286ca">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 190%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 133%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422303103513149441">
<div style="margin:1em 0">@WSJ How is this still a thing? I think (I may be mistaken) a federal judge said to turn them over, it went to SCOT… https://t.co/8XQF4mvqXj</div> — Jb (@Jb)
                        <a href="https://twitter.com/_john92_/statuses/1422303103513149441">1627938459.0</a>
</blockquote>
</div>
</div>
</div><p><br/></p><div class="rm-shortcode" data-rm-shortcode-id="c726352cd8700f1b46041c9581da8854" id="15cbf">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 130%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 72%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422317486926610432">
<div style="margin:1em 0">This is such a non surprise!! Trump really needs to keep his taxes away from Congressional oversight at any cost. H… https://t.co/t2HYoV7dfp</div> — Clare Warnagiris (@Clare Warnagiris)
                        <a href="https://twitter.com/CWarnagiris/statuses/1422317486926610432">1627941888.0</a>
</blockquote>
</div>
</div>
</div><p><br/></p><div class="rm-shortcode" data-rm-shortcode-id="eb797fa7cac71c70ec7312600f12c12c" id="d9b9c">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 136%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 80%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422308597355012099">
<div style="margin:1em 0">"There is no evidence of any wrongdoing here and I object to the release of the returns not only on behalf of my cl… https://t.co/jwTX2EKoDs</div> — Curious Dalek (@Curious Dalek)
                        <a href="https://twitter.com/curiousdalek/statuses/1422308597355012099">1627939769.0</a>
</blockquote>
</div>
</div>
</div><p><br/></p><div class="rm-shortcode" data-rm-shortcode-id="6f9b9bb00a1f476e00dc65e6d285e0ac" id="22dd7">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 138%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 104%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422318858199830534">
<div style="margin:1em 0">Put the returns out ASAP.He really must be hiding something bigtime.Or he's not at rich as he says!! https://t.co/HwbPQpWAxQ</div> — TruthIsSB (@TruthIsSB)
                        <a href="https://twitter.com/TruthIsSB1/statuses/1422318858199830534">1627942215.0</a>
</blockquote>
</div>
</div>
</div><p><br/></p>
<div class="rm-shortcode" data-rm-shortcode-id="87ac96f4a7b780302ead99de578f9b79" id="adfa8">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 165%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 125%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422312489254072325">
<div style="margin:1em 0">@JanNWolfe According to Trump's lawyer, "releasing his taxes would only serve to degrade him."

Now I really want to see them.</div> — Carlos Rosado (@Carlos Rosado)
                        <a href="https://twitter.com/crosado1968/statuses/1422312489254072325">1627940697.0</a>
</blockquote>
</div>
</div>
</div>
<p><br/></p>
<div class="rm-shortcode" data-rm-shortcode-id="c1c7b2706f5e4a4304d5022e870c7867" id="7643b">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 166%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 121%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422324502508277763">
<div style="margin:1em 0">If he is as honest as he claims to be, why panic? What's there to hide Donald? 🤣🤣🤣🤣🤣

Trump to object to release of… https://t.co/YrNd8nmLNy</div> — Ed Magana (@Ed Magana)
                        <a href="https://twitter.com/iNairobi/statuses/1422324502508277763">1627943561.0</a>
</blockquote>
</div>
</div>
</div>
<p><br/></p>
<div class="rm-shortcode" data-rm-shortcode-id="d5af8095cf9c296357766defbf659ae5" id="c3169">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 172%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 125%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422311957953081357">
<div style="margin:1em 0">@JanNWolfe As a private individual, how does Trump have standing to interfere in what amounts to a routine request… https://t.co/G3mqORHNFA</div> — ⚖️Dave Diamond Law🍷 Trump Killed John Prine (@⚖️Dave Diamond Law🍷 Trump Killed John Prine)
                        <a href="https://twitter.com/davediamondlaw/statuses/1422311957953081357">1627940570.0</a>
</blockquote>
</div>
</div>
</div>
<p><br/></p><div class="rm-shortcode" data-rm-shortcode-id="f1cae5f45328f5e0a597123cc2fa4659" id="41f02">
<div class="rm-embed-container rm-embed-twitter rm-loading">
<span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 114%"></span>
<span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 92%"></span>
<div class="rm-embed-holder">
<blockquote class="rm-embed twitter-tweet twitter-custom-tweet" data-partner="rebelmouse" data-twitter-tweet-id="1422314936273940480">
<div style="margin:1em 0">@thehill The audit in perpetuity. LMAO</div> — Rhonda Harbison (@Rhonda Harbison)
                        <a href="https://twitter.com/RonnieMotes8/statuses/1422314936273940480">1627941280.0</a>
</blockquote>
</div>
</div>
</div><p><br/></p></template></div>
            <div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds">
                <span class="show-more js-expand">CONTINUE READING</span>
                <span class="show-less js-contract">Show less</span>
            </div></div>
        

        

    </div>

<span class=""
    data-elid="2654378836"
    data-post-url="https://www.rawstory.com/trump-tax-returns-2654378836/"
    
        data-authors="Matthew Chapman"
    
    
        data-headline="&#39;He&#39;s hiding something&#39;: Trump mocked for desperate last-minute bid to stop Congress from getting his taxes"
    >
</span>
</div></div></div>
    
    
<script type="application/json" id="post-context-2654378836">
    {"customDimensions": {"7":"Matthew Chapman","8":"hot-off-the-wires","10":"08/02/2021","13":2654378836,"14":true,"15":false}, "post": {"providerId": 0, "sections": [0, 532450088, 537910665, 504781448, 502613554, 535969657], "buckets": [], "authors": [20272787]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div><!-- User Code --><div class='rs_ad_block story_page_add_wrap_after_2' style='margin: 0 auto; text-align: center; margin-top: 10px;'><div class="proper-ad-unit" style='min-height: 90px;'><div id="proper-ad-rawstory_content_10"></div></div></div>
<!-- End User Code --><div class="mb-2 post-head scroll-post" id="sPost_0_0_4_0_0_5_2_5_1_20"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_3"
        data-format="posts-custom"
        data-source="current_page"
        data-source-type="page"
        data-source-unique="true"
        data-section-id="0"
        data-is-reordable="true"
        data-using-stickers="true"
        data-has-more="true"

    
        data-attr-source="current_page"
        data-attr-all_share_buttons="Facebook,Twitter,Flipboard,CopyLink,Email,Linkedin,GooglePlus,Pinterest,Whatsapp,Reddit,Separator,Tumblr,SMS,Slack"
        data-attr-use_smart_keep_reading="true"
        data-attr-all_element_order="headline,author,date,body,section,community_name,subheadline,badges,badges_sponsored,photo_credit,photo_caption,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,date_modified,custom_field_smart_news_feed_headline,custom_field_Send-alternative-headline-to-smartnews,custom_field_is_survey_post,custom_field_survey_text_italic,custom_field_survey_text_red,product_prices,product_vendor,product_buy_link,words_count,time_to_read"
        data-attr-layout_all_date_format="%B %d, %Y"
        data-attr-show_more_button_text="CONTINUE READING"
        data-attr-layout_Whatsapp="inactive"
        data-attr-layout_Separator="inactive"
        data-attr-layout_Slack="inactive"
        data-attr-layout_all_subheadline_tag="h4"
        data-attr-source_unique="true"
        data-attr-section_url=""
        data-attr-layout_date="top"
        data-attr-data-rm-advanced="true"
        data-attr-source_url="current_page"
        data-attr-layout_Linkedin="inactive"
        data-attr-without_current="true"
        data-attr-layout_all_headline_tag="h2"
        data-attr-layout_Pinterest="inactive"
        data-attr-layout_author="top"
        data-attr-posts_id="sPost_0_0_4_0_0_5_2_5_1_20"
        data-attr-layout_Reddit="inactive"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-layout_body="bottom"
        data-attr-layout_headline="top"
        data-attr-format="posts-custom"
        data-attr-layout_Tumblr="inactive"
        data-attr-layout_SMS="inactive"
        data-attr-layout_all_image_crop="original"
        data-attr-element_classes="post-head scroll-post"
        data-attr-node_id="/root/blocks/block[post]/abtests/abtest[1]/choose[2]/otherwise/row/column[2]/posts[3]-"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_Email="active"
        data-attr-source_id="current_page"
        data-attr-layout_quality="5"
        data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix">
            
                
                <div class="widget"
                 elid="2654379553"
                data-category="Latest Headlines">
<article 
    elid="2654379553" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654379553" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://www.rawstory.com/florida-hospitalizations/"  aria-label="Florida COVID patient admits falling for &#39;foolish&#39; anti-vax lies: &#39;If I wasn’t stupid, I wouldn’t be in this predicament&#39;" data-type="text">
        Florida COVID patient admits falling for &#39;foolish&#39; anti-vax lies: &#39;If I wasn’t stupid, I wouldn’t be in this predicament&#39;
    </a>
</h2>


<div class="social-author clearfix">
    

    
        
    <div class="social-author__avatar image" >
             <div class="cover-all image" style='background-image: url("https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDgzNjE4NC9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY3NDk3MTAxNH0.f7RvUMoSVsGINpDf-_SIqlRaLaHPZ0v4Ax0Qhdb2yJA/image.gif?width=210")'></div>
        </div>
        <a class="social-author__name" href="https://www.rawstory.com/u/brad_reed" data-type="text">Brad Reed</a>
        
</div>
<div class="social-date">
        <span class="social-date__text">August 02, 2021</span>
    </div></div><div class="widget__head"><a href="https://www.rawstory.com/florida-hospitalizations/"  aria-label="Florida COVID patient admits falling for &#39;foolish&#39; anti-vax lies: &#39;If I wasn’t stupid, I wouldn’t be in this predicament&#39;">
                            
                            <div class="widget__image crop-980x559"
                                    role="img"
                                    aria-label="Florida COVID patient admits falling for &#39;foolish&#39; anti-vax lies: &#39;If I wasn’t stupid, I wouldn’t be in this predicament&#39;"
                                        
                                    data-runner-img-hd="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMjI1OS9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY5MTEwMjEyN30.FrTwgtvNTfFfVGdOTBKIKtZ_5UHFLJFmI4LvxoTnhdo/image.jpg?width=1200&amp;height=684"
                                    data-runner-img-md="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMjI1OS9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY5MTEwMjEyN30.FrTwgtvNTfFfVGdOTBKIKtZ_5UHFLJFmI4LvxoTnhdo/image.jpg?width=600&amp;height=342"
                                    data-runner-img-sd="https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMjI1OS9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY5MTEwMjEyN30.FrTwgtvNTfFfVGdOTBKIKtZ_5UHFLJFmI4LvxoTnhdo/image.jpg?width=300&amp;height=171"
                                    data-runner-style='padding-bottom: 57.0408163265%;'
                                    style='padding-bottom: 57.0408163265%;'
                                        data-type="image"
                            ><div class="lazyload-placeholder">
                                    <div class="runner-spinner">
                                      <svg class="runner-spinner-circular" viewBox="25 25 50 50">
                                        <circle class="runner-spinner-path" cx="50" cy="50" r="20" fill="none" stroke-width="3" stroke-miterlimit="10"/>
                                      </svg>
                                    </div>
                                </div></div>
                            </a>
                </div><div class="widget__body clearfix sm-mt-1"><div class="body js-expandable clearfix js-listicle-body  css-listicle-body-2654379553"
        ><div class="body-description"><div class="widget__brief"><p>A man who has been hospitalized for the last three weeks after being infected with the novel coronavirus admits that he got taken in by anti-vaccination propaganda -- and he's now full of regret.</p><p><a href="https://www.nbcnews.com/news/us-news/covid-surging-florida-doctors-nurses-are-back-crisis-mode-n1275746" target="_blank">NBC News reports</a> that 67-year-old Lawrence Jones, who has spent the past 22 days at UF Health Jacksonville after coming down with COVID-19, has been using his time to encourage more people to get vaccinated.</p></div>
            <div class="content-container"></div>
            <div class="js-appear-on-expand"><template><p>"Every day I get on the phone: 'Please do not play. Get the vaccination,'" he told the network. "If I wasn't stupid, I wouldn't be in this predicament. Don't listen to foolishness. Go get vaccinated."</p><p>Jones's story is part of a broader report on the surge of COVID hospitalizations in Florida, where Republican Gov. Ron DeSantis has refused to place any restrictions on the economy despite record-breaking cases.</p><p>Dr. Dean Watson, a vice president at Tallahassee Memorial Healthcare, tells NBC News that he's growing frustrated at having so many COVID patients who declined to get vaccinated despite having the opportunity to do so.</p><p>"We're taking care of patients who, if they had made the right choice and gotten the vaccine, would not be in the hospital," he said. "You're battling through sadness, but you're also battling through a little anger, too."</p></template></div>
            <div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds">
                <span class="show-more js-expand">CONTINUE READING</span>
                <span class="show-less js-contract">Show less</span>
            </div></div>
        

        

    </div>

<span class=""
    data-elid="2654379553"
    data-post-url="https://www.rawstory.com/florida-hospitalizations/"
    
        data-authors="Brad Reed"
    
    
        data-headline="Florida COVID patient admits falling for &#39;foolish&#39; anti-vax lies: &#39;If I wasn’t stupid, I wouldn’t be in this predicament&#39;"
    >
</span>
</div></div></div>
    
    
<script type="application/json" id="post-context-2654379553">
    {"customDimensions": {"7":"Brad Reed","8":"hot-off-the-wires","10":"08/02/2021","13":2654379553,"14":true,"15":false}, "post": {"providerId": 0, "sections": [0, 504781446, 532450088, 537910665, 504781448, 502613554, 535969657], "buckets": [], "authors": [20272778]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div><!-- User Code --><div id="comments_section_start" style="position: relative; top: -150px;">&nbsp;</div><div class='rs_ad_block story_page_above_comments' style='margin: 0 auto; text-align: center; '><div id='rc-widget-d9572f' data-rc-widget data-widget-host='habitat' data-endpoint='//trends.revcontent.com' data-widget-id='110322'></div></div>

<!-- End User Code --><!-- User Code --><div id="disqus_thread"></div><!-- End User Code --><!-- User Code -->
                    
                    
                    
          
          
              
              <!-- <div id="zergnet-widget-72546" style='margin: 15px 0 0 0; min-height: 540px;'></div>
//www.zergnet.com/zerg.js?id=72546  --><!-- MGID - RawStory - 3x2 below content (replace Zergnet) --><div id="M687751ScriptRootC1088602"></div><!-- End User Code -->
</div>



<div id="sPost_0_0_4_0_0_5_2_5_2" class="column-right sidebar-column col sm-mb-2 md-mb-4 s12 m12 l4">
    <div class="" id="sPost_0_0_4_0_0_5_2_5_2_0"><!-- User Code --><div id='sticky-container_1' class='alt_ad_block'><div id='sticky-target_1'><div class="proper-ad-unit" style="margin-top: 5px;"><div id="proper-ad-rawstory_side_1"></div></div></div></div><!-- End User Code --></div><!-- User Code --><div id="story_page_sidebar_piano"></div><!-- End User Code --><!-- User Code --><div class="proper-ad-unit" style="margin-top: 5px;"><div id="proper-ad-rawstory_side_2"></div></div><!-- End User Code --><!-- User Code --><div id='div-gpt-ad-1565199520698-0'></div><!-- End User Code --><!-- User Code --><div class="mgid_1x8"><div id="M687751ScriptRootC1087711"></div></div><!-- End User Code --><div class="sidebar-trending" id="sPost_0_0_4_0_0_5_2_5_2_7"><div class="text-element" id="sPost_0_0_4_0_0_5_2_5_2_7_0"> Trending Topics</div><div class="mb-2 sidebar-trending" id="sPost_0_0_4_0_0_5_2_5_2_7_1"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_4"
        data-format="posts-custom"
        data-source="frontpage_parent_site_trending-topics"
        data-source-type="page"
        data-source-unique="true"
        data-section-id="549655454"
        data-is-reordable="true"
        data-using-stickers="true"
        data-has-more="false"

    
        data-attr-layout_remove_image="true"
        data-attr-source_site="parent_site"
        data-attr-layout_body="bottom"
        data-attr-source_unique="true"
        data-attr-element_classes="sidebar-trending"
        data-attr-posts_id="sPost_0_0_4_0_0_5_2_5_2_7_1"
        data-attr-section_url="trending-topics"
        data-attr-headline_text=""
        data-attr-format="posts-custom"
        data-attr-data-rm-advanced="true"
        data-attr-source_url="trending-topics"
        data-attr-node_id="/root/blocks/block[post]/abtests/abtest[1]/choose[2]/otherwise/row/column[3]/element_wrapper[2]/posts-"
        data-attr-without_current="true"
        data-attr-all_element_order="body,headline,subheadline,section,author,community_name,date,date_modified,badges,badges_sponsored,photo_credit,photo_caption,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,custom_field_is_survey_post,custom_field_survey_text_italic,custom_field_smart_news_headline,custom_field_wevegotissues,custom_field_survey_text_red,product_prices,product_vendor,product_buy_link,custom_field_smart_news_feed_headline,custom_field_Send-alternative-headline-to-smartnews"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-layout_quality="9"
        data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix">
            
                
                <div class="widget"
                 elid="2651368033"
                data-category="Trending Topics">
<article 
    elid="2651368033" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-MD post-2651368033" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="body js-expandable clearfix js-listicle-body  css-listicle-body-2651368033"
        ><div class="body-description"><ul class="ee-ul"><li><a href="https://www.rawstory.com/who-is-jason-pirozzolo-politically-connected-florida-surgeon-reportedly-tied-to-gaetz-probe/" target="_blank">jason pirozzolo</a></li><li><a href="https://www.rawstory.com/aledo-school-slave-auction/" target="_self">texas high school auction black students</a></li><li><a href="https://www.rawstory.com/tito-ortiz-white-lives-matter-rally/" target="_blank">tito ortiz</a></li><li><a href="https://www.rawstory.com/cop-fired-caron-nazario/" target="_blank">caron nazario</a></li><li><a href="https://www.rawstory.com/newsmax-host-greg-kelly/" target="_blank">newsmax</a></li><li><a href="https://www.rawstory.com/bidens-sanctions-russia-solarwinds-hacking/" target="_blank">nancy sinatra</a></li><li><a href="https://www.rawstory.com/trump-legal-problems-2650010970/" rel="noopener noreferrer nofollow" target="_blank">roberta kaplan</a></li><li><a href="https://www.rawstory.com/derek-chauvin-emt-cops-cpr/" rel="noopener noreferrer nofollow" target="_blank">george floyd</a></li><li><a href="https://www.rawstory.com/maria-bartiromo-2650028761/" rel="noopener noreferrer nofollow" target="_blank">maria bartiromo</a></li><li><a href="https://www.rawstory.com/capitol-fire-extinguisher/" rel="noopener noreferrer nofollow" target="_blank">chris cuomo</a></li><li><a href="https://www.rawstory.com/matt-gaetz-money-exgirlfriend-trafficking/" rel="noopener noreferrer nofollow" target="_blank">matt gaetz girlfriend</a></li><li><a href="https://www.rawstory.com/matt-gaetz-2651336681/" rel="noopener noreferrer nofollow" target="_blank">gaetz harry potter</a></li></ul></div>
        

        

    </div>

<span class=""
    data-elid="2651368033"
    data-post-url="https://www.rawstory.com/trending-topics/"
    
        data-authors="Jamel Giuma"
    
    
        data-headline="Trending Topics"
    >
</span>
</div></div></div>
    
    
<script type="application/json" id="post-context-2651368033">
    {"customDimensions": {"7":"Jamel Giuma","8":"trending-topics","10":"04/05/2021","13":2651368033,"14":false,"15":false}, "post": {"providerId": 0, "sections": [549655454], "buckets": [], "authors": [20268615]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div></div><!-- User Code --><div class="proper-ad-unit"><div id="proper-ad-rawstory_side_3"></div></div><!-- End User Code -->

<div id="sPost_0_0_4_0_0_5_2_5_2_9"  class="rm-sticky-parent" >
    <span class="js-scroll-trigger" data-scope="next" data-triggers="sticky" data-target="#sticky-target-sPost_0_0_4_0_0_5_2_5_2_9" data-offset="110" data-toggle-class="sticky-active"></span>
    <div id="sticky-target-sPost_0_0_4_0_0_5_2_5_2_9" class="sticky-target">
        <div class="feed-network-wrap" id="sPost_0_0_4_0_0_5_2_5_2_9_0"><!-- User Code --><div class="proper-ad-unit proper-ad-rawstory_side_4_container"><div id="proper-ad-rawstory_side_4"></div></div><!-- End User Code --></div>
    </div>
    	
        	
        	
    
</div>
</div>


    
    
    
    </div>
</div>


<span class="js-brick-description hidden" data-name="Footer"></span><div id="sFooter_0_0_1_0_0_2" class=" row-wrapper clearfix  no-mb">
    <div class="row px20">
        

<div id="sFooter_0_0_1_0_0_2_0" class=" col sm-mb-2 md-mb-4 s12 m12 l12">
    <a id="sFooter_0_0_1_0_0_2_0_0"
    class="display-block image-element">
    <img
        class="image-element__img"
        alt=""
        width="405"
        height="65"src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yMzI4Mjc5NC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NzE0ODkzOX0.HMWM8a-NzoiyKFy2y27FgqeALFFx-lfXeylxl2rjaq8/img.jpg?width=405&amp;height=65"
    />
</a><div class="footer-newsletter" id="sFooter_0_0_1_0_0_2_0_1"><!-- User Code --><div id="lightbox-inline-form-37158095-34d0-4f8a-8053-c29b1f538491"></div><!-- End User Code --><!-- User Code --><div class='clear: both;'>&nbsp;</div><div class='rs_ad_block sitewide-footer' style='margin: 0 auto; text-align: center; min-height: 90px; min-width: 100%;'><div class='clear: both;'>&nbsp;</div><div class='rs_ad_block sitewide-head-justpremium' style='margin: 0 auto; text-align: center; min-height: 90px; min-width: 100%;'></div><div class='proper-ad-unit'><div id='proper-ad-rawstory_footer'></div></div><div id="story_page_footer_kindest_target"></div></div><!-- End User Code --></div>
</div>


    </div>
</div>


<!-- User Code --><div class="footer"><p>Copyright &#169; 2021 Raw Story Media, Inc. PO Box 21050, Washington, D.C. 20009 | <a href="/masthead" class="footer-link">Masthead </a> | <a href="/privacy-policy" class="footer-link">Privacy Policy </a> | For corrections or concerns, please email corrections@rawstory.com.</p><p><a href="javascript:googlefc.callbackQueue.push(googlefc.showRevocationMessage);" class="footer-link">Manage Preferences</a>  |  <a href='https://www.rawstory.com/st/rawstory-invest-in-reader-driven-journalism?piano=launch'>Piano Sign Up</a></p></div><div class="footer-debugs"></div><!-- End User Code --><!-- User Code --><style>

	#cp-popup-shadow {
		width: 100%;
		height: 20000px;
		background: #000;
		z-index: 1004459;
		opacity: 50%;
		position: absolute;
		left: 0;
		top: 0;
		display: none;
	}

	#cp-popup {
		/* background: #18803e; */
		background: #fff;
		min-height: 250px;
		width: 500px;
		z-index: 1004460;
		position: fixed;
		left: 50%;
		top: 50%;
		transform: translate(-50%, -50%);
		display: none;
	}

	.content-box {
	display: flex;
	flex-direction: column;
	margin-left: 15px;
    margin-top: 15px;
	}

	.sidebar-iframe-close {
	position: relative;
	width: 36px;
	height: 36px;
	cursor: pointer;
	z-index: 10;
	background-image: url('https://cdn.jsdelivr.net/fancybox/2.1.5/fancybox_sprite.png');
	display: block;
	top: 4px;
	float: right;
	background-color: transparent;
	border: none;
	margin-top: -20px;
	margin-right: -10px;
	}
  	.content-box .rsi-logo-image {
      width: 240px; height: auto;
      margin: 0 auto; z-index: 99;
  	}
    .content-box .rsi-logo-crossline {
      height: 1px;
      background: #000;
      position: relative;
      top: 50px;
    }
  	.content-box .appeal-text { 
      margin: 25px;
      font-size: 29px;
      text-align: center;
    }
  	.content-box .option-shadow {
      margin: 15px 50px;
      background: #000;
      position: re;
      top: 5px; 
      right: 5px;
  	}
  
    .content-box .option {
      background: #fff;
  	  border: 1px solid #000;
      text-align: center;
      font-size: 16px;
      line-height: .75em;
      font-weight: 700;
      position: relative;
      top: -5px;
      right: 5px;
      cursor: pointer;
  	}
  	.content-box .best-price-flag {
    	height: 1px;
  	}
  	.content-box .best-price-flag img {
      	position: relative; 
      	top: -50px;
      	left: 125px;
      	width: 200px;
  	}
  	.content-box .option-price {
      font-size: 14px;
      font-weight: 400;
  	}
  
	.alternet-image {
	width: 206px;
	height: 50px;
	margin: 40px auto 0 auto;
	}

	.main-title {
	color: #000;
	text-transform: uppercase;
	/*
    font-family: 'Fredericka the Great', cursive;
	font-family: 'Open Sans',sans-serif; */
    font-family: "Oswald";
	text-align: center;
	font-size: 32px;
	line-height: 20px;
	margin-top: 20px;
	letter-spacing: -1.5px;
	}
  
  	.red-font { color: red; }

	.text-p {
	text-align: center;
	color: #000;
	font-size: 16px;
	line-height: 25px; 
	margin: 10px 0;
	}

	#cp-popup-countdown-timer {
	color: white;
	text-transform: uppercase;
	font-family: 'Fredericka the Great', cursive;
	font-family: 'Open Sans',sans-serif;
	text-align: center;
	font-size: 14px;
	line-height: 35px;
	min-height: 35px;
	background: #000;
	}

	#cp-popup-conversion {
	background-color: #fff;
	color: #111;
    text-align: left;
	padding: 7px 10px;
	float: left;
	border: none;
	margin: 10px;
	width: 30%;
	opacity: .95;
	cursor: pointer;
	font-weight: bold;
	font-size: 11px;
	}
  	
  	#cp-popup-login {
	background-color: #fff;
	color: #111;
	text-align: right;
	padding: 7px 10px;
	float: right;
	border: none;
	margin: 10px;
	width: 45%;
	opacity: .95;
	cursor: pointer;
	font-weight: bold;
	font-size: 11px;
	}

	#cp-popup-conversion:hover {
	opacity: 1;
	}

	#cp-popup-conversion a {
	color: white;
	text-decoration: none;
	font-size: 15px;
	}

	#button-box {
		background-color: #fff;
      	/* 
      	background-color: #0b0d65;
		background-image: url('https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDk4MDQwOC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYxMzEyMzAzMH0.fgFR44zC5Hg8cpPcIXbX_CmjbCr0V4SPhYM5A1KSLxU/img.jpg'); */
		background-size: contain;
		background-repeat: repeat-x;
		width: 100%; min-height: 50px;
      	margin-top: 30px;
      	border-top: 2px solid black;
		text-align: center;
	}


	@media screen and (max-width: 499px) {

			
		#cp-popup {
			min-height: 250px;
			width: 90%;
			z-index: 1004460;
			position: absolute;
			left: 50%;
			top: 50%;
			transform: translate(-50%, -50%);
		}

		
		#cp-popup-countdown-timer {
		color: white;
		text-transform: uppercase;
		font-family: 'Fredericka the Great', cursive;
		text-align: center;
		font-size: 10.5px;
		line-height: 25px;
		min-height: 25px;
		background: #000;
		}

		#cp-popup-conversion {
			width: 50%;
			}

	}

</style><div id='cp-popup-shadow'></div><div id="cp-popup"><button id="cp-popup-close" class="sidebar-iframe-close"></button><div class="content-box"><div class='rsi-logo-crossline'></div><img class="rsi-logo-image" alt="" src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDQ3NDc3OC9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY3MDE2OTc5NX0.TtNCvbUSdchNj2PCGFT9XFHLMFXt_JW8uRISnljldp0/img.gif?width=240&height=87"><p class='appeal-text'>Don't Sit on the Sidelines of History.  Join Raw Story Investigates and Go Ad-Free.  Support Honest Journalism.</p><div class='popup-subscribe-options'><div class='option-shadow'><div class='option option-annually'><div class='best-price-flag'><img src='https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjAxNDAwNS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1MTA1NDc3N30.83uNhu0QuMl50Lutml0McLP5pCAP9RfYm4AR37oZGOA/image.png'></div><p class='option-name'>Subscribe Annually</p><p class='option-price'>$95 / year <span class='red-font'>&#8212; Just $7.91/month</span></p></div></div><div class='option-shadow'><div class='option option-monthly'><p class='option-name'>Subscribe Monthly</p><p class='option-price'>$1 trial</p></div></div><div class='option-shadow'><div class='option option-more'><p class='option-name'>I want to Support More</p><p class='option-price'>$14.99 per month</p></div></div></div></div><div id='button-box'><button id="cp-popup-conversion">LEARN MORE</button><button id="cp-popup-login">Already a member ? Login</button></div></div><!-- End User Code --><!-- User Code --><div class='rs_ad_block sitewide-lightbox-survey' style='margin: 0 auto; text-align: center; '></div><!-- End User Code --><!-- User Code -->
    <!-- RM VERSION
<div id='div-gpt-ad-1599648564111-0'><script>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1599648564111-0'); });
</script></div>
--><!-- OLD SCRIPT FROM WP --><!-- Undertone AdX Body --><!-- /1010624/Rawstory_Undertone_Desktop --><div id='div-gpt-ad-1578154939325-0'></div><div id='div-gpt-ad-1599648564111-0'></div><!-- /1010624/justpremium2021 --><div id='div-gpt-ad-1612555365328-0' style='width: 1px; height: 1px;'></div><!-- End User Code --><!-- User Code --><div id="nordotTag">{{ post.roar_specific_data.api_data.analytics }}</div><style>
  
#nordotTag{
 	display: none;
}

</style><!-- End User Code --><span class="js-brick-description hidden" data-name="CSSPost"></span></div>
            </div>
<noscript>
    <img src="http://b.scorecardresearch.com/p?cv=2.0&cj=1&c1=2&c2=32131503&c6=Latest+Headlines&c8=Trump-loving+Arizona+state+senator+pushes+for+mass+arrests+of+Maricopa+County+election+officials" />
</noscript><script>
    var _comscore = _comscore || [];
     _comscore.push({ c1: "2", c2: "32131503", c6: "Latest Headlines", c8: "Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials"});

    (function() {
        var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
        s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
        el.parentNode.insertBefore(s, el);
    })();
</script>


    
    


    
    


    



    

    

    

    

    
    


    

    

<ul id="notification" class="notification"></ul>




    
    <script defer src="https://www.googletagmanager.com/gtag/js?id=UA-18141479-1"></script><script>

            (function (i, s, o, g, r, a, m) {
                i["GoogleAnalyticsObject"] = r;
                (i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments);}),(i[r].l = 1 * new Date());
            })(window, document, "script", "/", "ga");
            ga('create', 'UA-18141479-1', 'auto', {'name': 'b'});

            window.dataLayer = window.dataLayer || [];
            window.gtag = function(){dataLayer.push(arguments);}
            gtag('js', new Date());

            var utmCampaignData = null;// ADD REFERRER AS SOURCE IF SOURCE IS NOT PRESENT OR IF ISN'T URL UTM
            if(utmCampaignData && (utmCampaignData.dataSource != "url" || !utmCampaignData['campaignSource'])) {
                var referrerAnchor = document.createElement('a');
                referrerAnchor.setAttribute('href', document.referrer);
                if(referrerAnchor.href && referrerAnchor.host) {
                    var splitHost = referrerAnchor.host.split(".");
                    var nakedDomain = splitHost.length < 3 ? splitHost[0] : splitHost[1];
                    if (nakedDomain) {
                        nakedDomain = nakedDomain[0].toUpperCase() + nakedDomain.substring(1);
                        utmCampaignData['campaignSource'] = nakedDomain;
                    }
                }
            }

            var configParams = { transport: 'beacon', send_page_view: false };
            // DEFAULTS
            if (utmCampaignData) {
                configParams.campaignName = utmCampaignData.campaignName;
                configParams.campaignSource = utmCampaignData.campaignSource;
                configParams.campaignMedium = utmCampaignData.campaignMedium;
                configParams.campaignContent = utmCampaignData.campaignContent;
                if (utmCampaignData.campaignKeyword) {
                    configParams.campaignKeyword = utmCampaignData.campaignKeyword;
                }
            }

            gtag('config', 'UA-18141479-1', configParams);

            <!-- ga_custom_dimensions: {u'layoutId': 11, u'postDate': 10, u'ATW_external': 15, u'postTags': 9, u'authorName': 7, u'primaryTag': 12, u'ATW_internal': 14, u'postID': 13, u'sections': 8} -->

          window._ga_cd_params = {};
          window._ga_cd_params["dimension7"] = "Brad Reed";
          window._ga_cd_params["dimension13"] = '2654381056';
          
          
          window._ga_cd_params["dimension8"] = 'hot-off-the-wires';
          
          window._ga_cd_params["dimension10"] = '08/02/2021';
          
          
          
          
          
          window._ga_cd_params["dimension11"] = 'google,clawback';
          
              window._ga_cd_params["dimension14"] = 'True';
            
              window._ga_cd_params["dimension15"] = 'False';
            
            if(window._ga_cd_params && Object.keys(window._ga_cd_params).length){
                gtag('event', 'page_view', window._ga_cd_params);
            }else{
                gtag('event', 'page_view');
            }
        </script>
    
    
    <script>
        if (typeof window.gtag === 'function') {
            var anchors = document.getElementsByTagName('a');
            for(var i = 0; i < anchors.length; i++) {
                var elem = anchors[i];
                elem.addEventListener('click', function (evnt) {
                    if (document.location.hostname === evnt.currentTarget.hostname) {
                        return;
                    }
                    if (!evnt.currentTarget.href) {
                        return;
                    }
                    if (evnt.currentTarget.href.lastIndexOf('javascript:', 0) === 0) {
                        return;
                    }
                    window.gtag('event', 'click', {
                        'event_category': 'outgoing_links',
                        'event_action': 'click',
                        'event_label': evnt.currentTarget.href,
                        'nonInteraction': 1,
                    });
                }, false);
            }
        }
    </script>
    
        <script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type":  "NewsArticle" ,
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.rawstory.com/wendy-rogers-arizona/"
        },
        "url": "https://www.rawstory.com/wendy-rogers-arizona/",
        "headline": "Trump-loving Arizona state senator pushes for mass arrests of Maricopa County election officials",
        "thumbnailUrl": "https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMzg0MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NTExMjUyMH0.9285uted0XHXZND3qB3e2gdAH_sJJwNi9ZipuOukFuc/image.jpg?width=210",
        "image": {
            "@type": "ImageObject",
            "url": "https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzExMzg0MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NTExMjUyMH0.9285uted0XHXZND3qB3e2gdAH_sJJwNi9ZipuOukFuc/image.jpg?width=1200&coordinates=0%2C66%2C0%2C0&height=600",
            "width": 1200,
            "height": 600
        },
        "datePublished": "2021-08-02T23:38:09Z",
        "dateModified": "2021-08-02T23:39:27Z",
        "author": {
            "@type": "Person",
            "name": "Brad Reed"
        },
        "publisher": {
        "@type": "Organization",
        "name": "Raw Story - Celebrating 17 Years of Independent Journalism",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.rawstory.com/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNDk4MDQwMC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0NTg5Njc0NH0.2k-i0Bmt9G9sEw2sThL5Lif6YvM-wT4jdowU5K9cWVg/image.jpg?width=210"
            }
        },
        "description": "Trump-loving Arizona State Sen. Wendy Rogers lashed out at the Maricopa County Board of Supervisors after it refused to comply the Arizona Republicans' demands for more information related to the Trump-backed \"audit\" of the 2020 election.After Jack Sellers, the chair of the board, wrote a snide lett...",
        "keywords": []}
</script>


    <script class="lazy-style" type="css">
        

    </script>

    <script id="user-javascript-medium-normal">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</script>
    <script id="user-javascript-active" type="text">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</script>
    <script id="user-javascript-lowest" type="text">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</script>
</body>
</html>